दिलचस्प पोस्ट
कौन कह रहा इस प्रोग्रामिंग लिखा था? "हमेशा कोड ऐसा होता है कि जो आदमी आपका कोड बनाए रखता है वह एक हिंसक मनोचिकित्सक होगा जो यह जानता है कि आप कहां रहते हैं।" ISO C90 सी में मिश्रित घोषणाओं और कोड को रोकता है लॉगरिदमिक एक्सिस लेबल्स / टिक्स कस्टमाइजेशन कैसे जावा में एक अवधि को प्रारूपित करें? (जैसे प्रारूप एच: एमएम: एसएस) क्या कंसोल आउटपुट को रोकना संभव है? जावा में पूर्वानुमान Uncaught सिंटेक्स त्रुटि: JSON.parse के साथ अनपेक्षित टोकन एमएस एक्सेस क्वेरी: एक क्वेरी के माध्यम से पंक्तियाँ जोड़ना गणितीय अभिव्यक्तियों का मूल्यांकन करने का सर्वोत्तम और सबसे छोटा तरीका मैं किसी स्ट्रिंग को एक अल्पसंख्यक हजार विभाजक के साथ किसी संख्या में कैसे पार्स कर सकता हूं? C ++ फ़ंक्शन पॉइंटर प्रकार के रूप में कक्षा विधि का उपयोग करना रिवर्स इंजीनियरिंग को एक डेटाबेस में नेविगेशन प्रॉपर्टी नामों में सुधार करें जब आप क्रोमेडरियर के साथ सेलेनियम का उपयोग कर रहे हैं तो क्या कोई वेबसाइट पता लगा सकती है? बनाम find_by बनाम खोजें एक वर्ग क्यों मुहर?

सिम्युलेटर में ऐप चलाने में असमर्थ: Xcode बीटा 6 IOS 8

मैं एक्सकोड 6 बीटा और आईफोन 5 एस सिम्युलेटर का उपयोग कर सिम्युलेटर पर अपना ऐप लॉन्च करने में असमर्थ हूं। सबसे पहले मुझे सिम्युलेटर "आईओएस सिम्युलेटर को बूट करने में असमर्थ" से एक त्रुटि संदेश मिल रहा है, और फिर एक्सकोड मुझे निम्नलिखित त्रुटि दिखा रहा है,

Xcode त्रुटि

वेब के समाधान से एकत्रित समाधान "सिम्युलेटर में ऐप चलाने में असमर्थ: Xcode बीटा 6 IOS 8"

मैंने इन चरणों का हल किया:

  1. ओपन एक्सकोड 6 बीटा
  2. मेनू Xcode> ओपन डेवलपर टूल> iOS सिम्युलेटर पर जाएं
  3. यहां तक ​​कि अगर कोई त्रुटि संवाद दिखाई देता है, तो आप अभी भी iOS सिम्युलेटर के मेनू तक पहुंच सकते हैं
  4. हार्डवेयर> डिवाइस> उपकरण प्रबंधित करें चुनें
  5. नीचे दिए गए छोटे + चिह्न पर क्लिक करें
  6. जो सभी डिवाइस आप चाहते हैं (यदि अनुपलब्ध है) जोड़ें, या हटाएं और लोगों को खराब करने के लिए पुन: बनाएँ।
  7. यदि सिम्युलेटर में से कोई भी काम नहीं कर रहा है तो उस पर राइट क्लिक करें और इसे हटा दें और फिर इसे फिर से बनाएं

यहां छवि विवरण दर्ज करें

  • सुनिश्चित करें कि आप Preferences> Locations अनुभाग में कमांड लाइन टूल्स के रूप में XCode6 चुनते हैं

XCode6 प्राथमिकताएं

  • सुनिश्चित करें कि आप XCode 6 खोलें, जो कि सेटअप फ़ाइल से नहीं हैं

  • अंत में मैक को पुनरारंभ करना मेरे मामले में समस्या का समाधान करता है

वेब पर कुछ समाधान मिलने के बाद, प्रक्रियाओं का एक संयोजन मेरे लिए काम करता था:

  1. Xcode और IOS सिम्युलेटर बंद करें (और सभी संबंधित एप्लिकेशन)

  2. Xcode6-Beta को एप्लिकेशन फ़ोल्डर में स्थापित करें (या पुनर्स्थापित करें) (.dmg फ़ाइल से सीधे)

  3. Xcode6- बीटा खोलें और Xcode -> वरीयताएँ -> स्थान -> कमांड लाइन टूल पर जाएं और "Xcode 6.0" चुनें (सुनिश्चित करें कि आपने एप्लिकेशन फ़ोल्डर में एक को चुना है)

  4. आईओएस सिम्युलेटर लॉन्च करें और आईओएस सिम्युलेटर पर जाएं -> सामग्री और सेटिंग्स रीसेट करें …

  5. सभी एप्लिकेशन बंद करें और अपने मैक को पुनरारंभ करें (मैं "विंडो को फिर से खोलें …" अनचेक करें)

  6. Xcode6-बीटा खोलें और IOS सिम्युलेटर का परीक्षण करें

सौभाग्य

मैं XCode 6 beta2 का उपयोग कर रहा हूं और समस्या (त्रुटि कोड = मेरे मामले में = 4) आईपैड सिमुलेटरों को चलाने में है मुझे लगता है कि मुझे इस समस्या थी क्योंकि मैं दोहरी मैक ओएस बूट चला रहा हूं और एक्सकोड दूसरे स्टार्टअप डिस्क से लॉन्च किया गया है

मैंने @यालकंकाया और @ पास्कुअल द्वारा सुझाए गए दोनों चरणों को किया, और यह मेरे लिए काम किया

  • "कमांड लाइन टूल" को XCode BETA2 (मेरे मामले में 5.1.1 से) में बदलें "XCode-> Preference-> Locations"
  • ओपन एक्सकोड 6 बीटा 2
  • मेनू Xcode> ओपन डेवलपर टूल> iOS सिम्युलेटर पर जाएं
  • यहां तक ​​कि अगर कोई त्रुटि संवाद दिखाई देता है, तो भी आपके पास आईओएस सिम्युलेटर के मेन्यू का उपयोग करना होगा हार्डवेयर> उपकरण चुनें, और आईपैड डिवाइसों के बीच स्विच करें और यह जाहिरा तौर पर सिम्युलेटर को फिर से कॉन्फ़िगर किया गया
  • जबकि सिम्युलेटर चल रहा है, चयनित सिम्युलेटर के साथ ऐप को चलाएं।
  • इस मैनुअल प्रक्रिया को एक बार जाकर, सब कुछ ठीक है।

यह ज्यादातर समय होता है क्योंकि सिम्युलेटर का एक और उदाहरण गोदी में चल रहा है।

अन्य उदाहरण को मार डालें और चीजें ठीक काम करना चाहिए।

मुझे भी यह समस्या थी और निम्नलिखित कदम उठाकर समाधान मिला: –

1) Initially i downloaded Xcode 6 library in Documentation section under the path Xcode --> Preferences --> Downloads and restart my xcode but didn't solve my problem. After that -> 2) Downloaded and installed the iOS 7.1 Simulator under the path Xcode --> Preferences --> Downloads. Restart xcode again and the problem solved. 3) I am facing same issue again next morning. Unsetting the DYLD_INSERT_LIBRARIES variable solves my problem:- a) Open terminal and type "sudo vi /etc/launchd.conf" command and press Enter b) Press I "Insert" mode and change this "setenv DYLD_INSERT_LIBRARIES /usr/lib/libimckit.dylib" to this "unsetenv DYLD_INSERT_LIBRARIES /usr/lib/libimckit.dylib" and press esc to exit from insert mode. c) Save changes by typing ":wq" Press Enter d) Reboot your system and problem soloved. 

यहां छवि विवरण दर्ज करें

 Prior to that i didn't found any iOS version in front of each listed devices but after installation or by unsetting DYLD_INSERT_LIBRARIES variable i found the same in front of each devices. 

> यहां छवि विवरण दर्ज करें

उम्मीद है कि यह किसी को भी मदद करता है

मुझे "Xcode-Beta2" से "Xcode" नाम का डिफ़ॉल्ट फ़ोल्डर नाम बदलने के बाद मुझे यह समस्या मिल गई है जब मैंने इसे "एक्सकोड-बीटा 2" में बदल दिया, तो सिम्युलेटर पहले से ही काम करता था

मेरे लिए क्या काम "डिवाइस प्रबंधित करें" में सभी उपकरणों को हटा रहा था और रिबूट करने के बाद उन्हें वापस जोड़ रहा था

क्लीन -> चलाएं मेरे लिए इसे तय किया

मैंने आराम की कोशिश की है, कुछ भी मदद नहीं की हालांकि यह भी आवश्यक हो सकता है

मेरे पास एक ही समस्या थी, जब पहले चलाए जाने वाले अलग-अलग ऐप के समान नाम के साथ एक ऐप चलाते समय

"Foo" -> "foo" -> run -> त्रुटि नाम का एक नया प्रोजेक्ट चलाएं।

जो भी – मुझे लगता है कि आईओएस सिम्युलेटर के लिए कई कारण हैं "ईएमएम, आप मुझसे क्या चाहते हैं? ठीक है, मैं एक त्रुटि फेंक दूँगा …" 😉

मेरा समाधान: आईओएस सिम्युलेटर बंद करें, फिर से ऐप चलाएं।

यह इस तरह के अधिकांश मामलों में है

मेरे लिए, मैं बस डेवलपर केंद्र से एक्सकोड को अपडेट नहीं किया था जो अब 6 X 6 Xcode था। मैं स्वचालित ऐप स्टोर अपडेट के साथ खराब हो गया था, और पुराने मैन्युअल डाउनलोड प्रक्रिया के बारे में भूल गया था।

त्रुटि रिपोर्टिंग के लिए सबसे आम कारण यह है कि DYLD_INSERT_LIBRARIES सेट है। इस समस्या की रिपोर्ट करने वाले अधिकांश लोग इसे /etc/launchd.conf में सेट करते हैं। आप उस फ़ाइल को हटाने के लिए इसे संपादित कर सकते हैं (या सिर्फ उस फ़ाइल को केवल एक ही पंक्ति के रूप में हटा दें) और समस्या को हल करने के लिए रीबूट करें

इस समस्या का एक अन्य संभावित कारण यह है कि आप पहली बार इसे चलाने के बाद Xcode.app का नाम बदल सकते हैं। अगर ऐसा मामला है, तो बस रिबूट करें (या इसे पहले नाम से बदला दें)

मैंने सब कुछ ऊपर की कोशिश की है

लेकिन यह पाया कि मुझे आईओएस 8.1 काम करने के लिए नवीनतम ओएस एक्स 10.10.1 (ओएस एक्स 10.9.5 से) में अपडेट करना होगा

हां अपस्कुअल सही है https://stackoverflow.com/a/24080160/2905967

लेकिन मेरे लिए, चरण 5 से पहले, मैंने सिम्युलेटर डिवाइस को हटा दिया है (कुंजीपटल से हटाए गए कुंजी का चयन करें और दबाकर) जो डिवाइस समस्या दे रहा है संदर्भ: एपस्कुअल जवाब

ये कदम आपकी समस्या के साथ आपकी सहायता कर सकते हैं। इसे इस्तेमाल करे:

1 (अपनी स्क्रीन के शीर्ष पर आईओएस सिम्युलेटर को क्लिक करें

2 (सामग्री और सेटिंग्स रीसेट करें क्लिक करें

3 (अलर्ट आने पर रीसेट करें क्लिक करें

4 (सिम्युलेटर पर फिर से एप्लिकेशन चलाएं

इससे पहले ही आईओएस सिम्युलेटर पर सभी सामग्री और सेटिंग्स को रीसेट कर दिया जाएगा।

उम्मीद है कि यह त्रुटि के साथ मदद करता है

मेरे पास एक ही समस्या थी और केवल समाधान था जिससे मुझे यह तय करने में मदद मिली कि Xcode को फिर से स्थापित करना था।

सिम्युलेटर / एस हटाना और Xcode / विंडो / उपकरण में फिर से मेरे लिए काम किया …

जब तक मैं Xcode 6-beta अनुप्रयोग फ़ाइल को एक फ़ोल्डर के अंदर से नहीं रखता, तब तक मुझे यह समस्या थी कि मैं अपनी एप्लिकेशन निर्देशिका में अनुप्रयोग निर्देशिका में ही गया था। पुनरारंभ कंप्यूटर फिर यह काम किया।

परीक्षण करने के लिए, मैंने अपनी एप्लिकेशन निर्देशिका में एक फ़ोल्डर फिर से बनाया और मेरे Xcode एप्लिकेशन को वहां रख दिया और फिर से, यह काम नहीं किया। इसे वापस आवेदन निर्देशिका में रखो; इसने काम कर दिया। मुझे इन मामलों में पुनरारंभ करने की ज़रूरत नहीं थी

मैं सच में आशा करता हूं कि ऐप्पल हार्डकोडिंग पथ से परे है।

मुझे एक ही समस्या का सामना करना पड़ रहा था, मैंने जो किया है IOS7 के लिए सिम्युलेटर डाउनलोड किया है कि आपको क्या करने की आवश्यकता है: – 1.Xcode-> प्राथमिकताएं-> डाउनलोड-> अवयव 2. उसके बाद सामान्य रूप से आपके सिस्टम में सामान्य सेटिंग्स के तहत तैनाती लक्ष्य 7.0 के रूप में 3. अंतिम बात 7.0 के तहत किसी भी सिम्युलेटर का चयन है 🙂

मुझे आईफोन सिम्युलेटर पर केवल एक आईपैड को चलाने की कोशिश में यह त्रुटि मिली यह एक सार्वभौमिक ऐप के रूप में बनाया गया है, मैंने इसे परीक्षण के लिए आईफोन पर कई बार चलाया है, और मैंने हाल ही में लक्ष्य कॉन्फ़िग में "iPad" केवल चेकबॉक्स की जांच की है।

मेरे आईफोन डिवाइस पर इसे चलाने की कोशिश करते समय, मुझे और अधिक उपयोगी त्रुटि संदेश मिला: "[/ location / / / name.app पर आवेदन] केवल आईपैड पर स्थापित किया जा सकता है।"