दिलचस्प पोस्ट
फ़ोन नंबर को तेजी से कॉल करना GetAttribute () और getParameter () के बीच का अंतर समूह का समय घंटा या 10 मिनट तक कैसे करें अजगर: एन-लगभग-बराबर-लम्बी विभाजनों में एक सूची का टुकड़ा करना साइलेंट पुश अधिसूचना क्या है? उपकरण कब प्राप्त होता है? किसी विशिष्ट संपत्ति पर LINQ का विशिष्ट () MySQL डाटाबेस के साथ पायथन 3.4.0 PHP का उपयोग कर एक बड़ी फ़ाइल स्ट्रीमिंग क्या वास्तव में nullptr है? जेपीए एनोटेशंस के साथ MYSQL ऑटोनाममेंट फ़ील्ड को कैसे एनोटेट किया जाए तालिका नाम सेट करने के लिए तैयार वक्तव्य का उपयोग करना .NET के लिए कोई सभ्य पाठ diff / मर्ज इंजन? एंड्रॉइड: मैं अपने दृष्टिकोण को धक्का देने से नरम कीबोर्ड को कैसे रोकूं? Java EE अनुप्रयोग को स्थापित करने के लिए अच्छा InstallAnywhere प्रतिस्थापन क्या हैं? सभी एंड्रॉइड संपर्क कैसे प्राप्त करें, लेकिन सिम पर हैं बिना

एलेप्से प्रोजेक्ट के लिए जेडीके संस्करण कैसे बदला जाए

मुझे एक ऐसी परियोजना लिखनी है जो केवल जावा 1.5 के साथ संगत है। मेरे पास जावा 1.6 स्थापित है क्या एक्लिप्स को 1.5 के साथ संकलित करने के लिए पिछली संगतता का कोई रूप है?

क्या मुझे यहां जावा दिखाने के लिए जावा 1.5 इंस्टॉल करना है? या फिर एक और तरीका है?

यहां छवि विवरण दर्ज करें

वेब के समाधान से एकत्रित समाधान "एलेप्से प्रोजेक्ट के लिए जेडीके संस्करण कैसे बदला जाए"

लाइब्रेरी जोड़ें बटन पर क्लिक करें। यह आपकी स्क्रीन को जावा स्थान को इंगित करने के लिए लाता है।

" डायरेक्टरी " का चयन करें, जेआरई होम के ठीक ऊपर बटन और इंस्टॉल किए गए फोल्डर स्थान को इंगित करें।

भले ही आप सिर्फ 1.5 कंपाइलर प्रोजेक्ट करना चाहते हैं, तो आप इसे 1.6 जेआरई हटाने और 1.5 जेआर जोड़ने के बजाय एक्लिप्से में कंपाइलर सेटिंग बदल कर प्राप्त कर सकते हैं।

GOTO -->JAVA--Compiler---> and change compiler level to `1.5` instead of `1.6` 

जैसा कि दाविदफेट्ससन ने सुझाव दिया,

बस सावधान रहें, खासकर यदि आप इसे काम करने के लिए लोगों की एक टीम के लिए स्थापित कर रहे हैं। यदि कोई भी नया उपयोग करता है या 1.6 में बदलता है, तो यह संकलन करेगा, लेकिन JRE 1.5 के साथ एक वातावरण में नहीं चलाया जाएगा।

एक्लिप्स में विंडो टैब पर क्लिक करें, प्राथमिकताएं पर जाएं और जब उस विंडो में आता है, तो जावा → इंस्टाल किया गया JREsएक्ज़ीक्यूशन एनवायरमेंट पर जाएं और जावासे-1.5 चुनें। फिर आपको कंपाइलर पर जाना होगा और कंपाइलर अनुपालन स्तर सेट करना होगा।

JRE बदलने

यहां छवि विवरण दर्ज करें

राइट क्लिक प्रोजेक्ट -> गुण -> जावा बिल्ड पथ -> जेआरई सिस्टम लाइब्रेरी चुनें> संपादित करें और जेडीके या जेआरई का चयन करें, उसके बाद जावा कंपाइलर पर क्लिक करें और कम्पाइलर अनुपालन स्तर को 1.8 पर क्लिक करें

यहां छवि विवरण दर्ज करें

यहां छवि विवरण दर्ज करें

यहां छवि विवरण दर्ज करें

ग्रहण-विशिष्ट परियोजना परिवर्तन जेडीके संस्करण –

यदि आप एक विशिष्ट प्रोजेक्ट के किसी भी जेडीके संस्करण को बदलना चाहते हैं तो —> परियोजना -> जेआरई सिस्टम लाइब्रेरी -> गुण — अंदर-अंदर क्लासपाथ कंटेनर (जेआरई सिस्टम लाइब्रेरी) में निष्पादन पर्यावरण को बदलना है कभी संस्करण आप चाहते हैं जैसे 1.7 या 1.8

ईक्लीप्स में पेज सेट अप जेडीके देखें। जोड़ बटन से आप जेडीके का एक अलग संस्करण जोड़ सकते हैं …

ग्रहण शुरू करने के लिए इस्तेमाल किए जाने वाले जेडीके (जावावाइम) जरूरी नहीं कि आपकी परियोजना को संकलित करने के लिए इस्तेमाल किया गया है।

यह देखने के लिए कि आप अपनी प्रोजेक्ट के लिए JRE का चयन कैसे कर सकते हैं, प्राथमिकताएं जांचें:

सामान्यजावा स्थापित JRE

डिफ़ॉल्ट रूप से, यदि आपने कोई भी जेआरई नहीं जोड़ा है, तो घोषित एक ही होगा जो ईक्लिप्स को लॉन्च करने के लिए उपयोग किया जाता है (जिसे आपके eclipse.ini में परिभाषित किया जा सकता है)।

आप चाहते हैं कि किसी भी अन्य JRE को जोड़ सकते हैं, जिसमें आपकी परियोजना के साथ एक संगत है।

इसके बाद, आपको अपने प्रोजेक्ट प्रॉपर्टी (या सामान्य वरीयताओं में) की जांच करनी होगी कि क्या अनुपालन स्तर के साथ जेआरई का उपयोग किया जाता है:

Alt पाठ http://www.standartux.fr/public/Java/Preferences.png

जावा के तहत प्राथमिकताएं अनुभाग में -> स्थापित JREs जोड़ें बटन पर क्लिक करें और 1.5 जेडीके होम फ़ोल्डर पर जाएं। तब सूची में से एक को जांचें और यह सभी परियोजनाओं के लिए डिफ़ॉल्ट हो जाएगा:

यहां छवि विवरण दर्ज करें

जैसा कि मैंने इस मुद्दे का कुछ मिनट पहले सामना किया था, अगर आप एक नया जेडीके के साथ एक पर्यावरण में एक मौजूदा प्रोजेक्ट को खोलने की कोशिश कर रहे हैं, तो सुनिश्चित करें कि आप प्रोजेक्ट गुण -> परियोजना के पहलू -> जावा में जेडीके संस्करण को पीडीट करते हैं।