Articles of एंड्रॉइड ग्रेडेल

प्लगइन बहुत पुराना है, कृपया एक अधिक हाल के संस्करण में अपडेट करें, या ANDROID_DAILY_OVERRIDE परिवेश चर को सेट करें

आज मैंने एंड्रॉइड एसडीके से मेरे प्रोजेक्ट (एनालिटिक्स) के एक मॉड्यूल के रूप में सिर्फ एक नमूना ऐप आयात किया है और जब मैं इसे सिंक करने की कोशिश करता हूं तो अचानक मुझे यह क्राउडेल त्रुटि मिलती है: Plugin is too old, please update to a more recent version, or set ANDROID_DAILY_OVERRIDE envrinment variable […]

Android Gradle प्लगइन 0.7 के साथ एनडीके को कॉन्फ़िगर कैसे करें

नए एंड्रॉइड ग्रेडले प्लगइन (0.7) में एनडीके के लिए नया समर्थन शामिल है, लेकिन दस्तावेज में इसका कोई जिक्र नहीं है (केवल एक संदर्भ जो मैंने पाया है वह ndkSanAngeles नामक ndkSanAngeles )। ऐसा लगता है कि ग्रेड्रे एनडीके की तलाश कर रहा है, जिसे मैंने अपने पाथ में शामिल किया है। हालांकि, परियोजना के […]

: एप: डीएक्सडीबॉग एक्जिक एक्स्प्शन गैर-शून्य निकास मूल्य 2 के साथ समाप्त हुआ

क्या कोई मुझे निम्नलिखित त्रुटि से मदद कर सकता है? जब मैं इस परियोजना को साफ करता हूं, कोई त्रुटि नहीं दिखाती है, लेकिन हर बार मैं इस संदेश को चलाने के लिए कोशिश करता हूं। त्रुटि: कार्य निष्पादन के लिए विफल ': app: dexDebug' com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: प्रक्रिया 'कमांड' सी: \ प्रोग्राम फ़ाइलें \ Java […]

Android स्टूडियो में 'ऑफ़लाइन मोड' को कैसे निष्क्रिय करें?

मैं एंड्रॉइड स्टूडियो आईडीई विकास के लिए नया हूँ हर बार जब मैंने एक सैंपल प्रोजेक्ट आयात किया था जो एंड्रॉइड स्टूडियो में विकसित हुआ था, तो मुझे यह त्रुटि मिल रही है .. ऑफ़लाइन मोड के लिए उपलब्ध com.android.tools.build:gradle:1.1.0 का कोई कैश्ड संस्करण नहीं है। ग्रेड 'ऑफ़लाइन मोड' अक्षम करें और परियोजना समन्वयन करें […]

सामान्य के लिए ट्रांसफार्म एक्स्प्शन डुप्लिकेट प्रविष्टि.नोटेशन। बीटा

यह शुरू हुआ जब मैंने google-api-services-calendar जोड़ा था बनाने की कोशिश करते समय मुझे यह त्रुटि मिल रही है: Error:Execution failed for task ':app:transformClassesWithJarMergingForDebug'. com.android.build.transform.api.TransformException: java.util.zip.ZipException: duplicate entry: com/google/common/annotations/Beta.class चलने पर यह उत्पादन का एक हिस्सा है ./gradlew app:dependencies : compile – Classpath for compiling the main sources. +— com.google.android.gms:play-services-measurement:8.1.0 | +— com.google.android.gms:play-services-base:8.1.0 | | […]

सार्वजनिक रूप से खुलासा स्रोत कोड के बिना एक ग्रेगुल के साथ एक एंड्रॉइड लाइब्रेरी जार कैसे बना सकता है?

मैं एक एंड्रॉइड लाइब्रेरी प्रोजेक्ट से एक जार बनाना चाहता हूं। इसे निम्नलिखित तरीके से सेट किया गया है: ProjectName \- lib | \- lib | \- armeabi | \- libNativeFirst.so | \- libNativeSecond.so \- src \- main \- java \- com.package.sdk \- PackageSDK.java मैं इस सबके लिए एक जार में पैक किया जाना चाहता […]

एक डिवाइस पर ContentProvider का उपयोग करने वाले समान ऐप को चलाने के लिए ग्रैड में बिल्ड प्रकारों का उपयोग करना

मैंने अपने डीबग ऐप में पैकेज नाम प्रत्यय जोड़ने के लिए ग्रैडल की स्थापना की है इसलिए मुझे रिलीज़ संस्करण मिल सकता है जो मैं एक फोन पर संस्करण का उपयोग कर रहा हूं और डीबग कर रहा हूं। मैं इसे संदर्भित कर रहा था: http://tools.android.com/tech-docs/new-build-system/user-guide#TOC-Bild-Types मेरा build.gradle फ़ाइल इस तरह दिखता है: … android […]

एंड्रॉइड 6.0 (मार्शमॉल) के साथ अपाचे एचटीटीपी कनेक्शन

क्या एंड्रॉइड 6.0 के साथ काम करने के लिए अपाचे लायब्रेरी सीधे ग्रैडल में शामिल करने का कोई तरीका है? मैंने इस तरह की पुस्तकालयों को शामिल करने की कोशिश की है: compile 'org.apache.httpcomponents:httpcore:4.4.1' compile 'org.apache.httpcomponents:httpclient:4.5' एंड्रॉइड स्टूडियो निम्न आयात को खोजने के लिए प्रबंधित नहीं कर सका: import org.apache.http.auth.AuthenticationException; import org.apache.http.auth.Credentials; import org.apache.http.auth.MalformedChallengeException; import […]

त्रुटि: Android स्टूडियो में नाम 'डिफ़ॉल्ट' के साथ कॉन्फ़िगर नहीं मिला

मैं एंड्रॉइड में नेटवर्क ऑपरेशन करने के लिए वॉली लाइब्रेरी का उपयोग कर रहा हूं। इसलिए मैं अपनी प्रोजेक्ट में यह लाइब्रेरी जोड़ने का प्रयास कर रहा हूं जो एंड्रॉइड स्टूडियो और क्राउडेल सिस्टम में बनाया गया है। मैंने अपनी प्रोजेक्ट में वॉली लाइब्रेरी को जोड़ा लेकिन जब मैं ग्रेडले के साथ सिंक करता हूं […]

buildTypes को groovy.lang.Closure पर लागू नहीं किया जा सकता

मुझे मेरी प्रोजेक्ट ग्रेडल फाइल में यह चेतावनी मिल रही है: चेतावनी: (16, 5) 'बिल्डटैप' को '(groovy.lang.closure <com.android.build.gradle.internal.dsl.BuildType>) पर लागू नहीं किया जा सकता' मेरा बिल्डटैप्स अनुभाग है: buildTypes { debug { debuggable true } release { minifyEnabled true proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-project.txt' } } मैं वर्तमान में एंड्रॉइड स्टूडियो 1.1.0 का उपयोग कर रहा हूँ, […]

दिलचस्प पोस्ट
स्ट्रीम दो बार पढ़ें Git – चयनित फ़ाइल पर संघर्ष विलय और मैन्युअल मर्ज करने के लिए मजबूर कैसे करें अनुप्रयोगों को रूट व्यू नियंत्रक कंसोल होने की उम्मीद है एक्सप्लोरर की तरह फ़ोल्डर ब्राउज़र नियंत्रण कैसे बनाएं? अजगर में एन-ग्राम, चार, पांच, छ: ग्राम? JavaScript के साथ यूआरएल हैश / टुकड़ा पहचानकर्ता को पार्स करना रूट के सापेक्ष लिंक होने के नाते? Numpy array में निकटतम मान ढूंढें तारों के लिए जावा आउटपुट स्वरूपण क्या कोई बेहतर विंडोज कंसोल विंडो है? मैं नेस्टेड / रिकर्सिव डिक्शनरी और लिस्ट में deserialize करने के लिए JSON.NET का उपयोग कैसे करूं? PHP का उपयोग करके सीएसआरएफ टोकन को ठीक से कैसे जोड़ सकते हैं जावाएफएक्स के वेबइंजिन / वेबव्यू का उपयोग करके कुकी सेट करना किसी दूसरे वर्ग में चल रहे अन्य धागे से UI को कैसे अपडेट किया जाए मणि स्थापित करने के लिए कैसे – non-ri –no-rdoc डिफ़ॉल्ट बनाने के लिए?