दिलचस्प पोस्ट
त्रुटि: सेटअप स्क्रिप्ट त्रुटि से बाहर निकल गई: कमांड 'x86_64-linux-gnu-gcc' से बाहर निकलने की स्थिति 1 में विफल कैसे एक SearchView के साथ एक RecyclerView फ़िल्टर करने के लिए स्प्रिंग में जेएसएफ व्यू स्कोप इकाई के लिए लिनक – एसक्यूएल "इन" क्लॉज CLOCK_REALTIME और CLOCK_MONOTONIC के बीच का अंतर? मैं कैसे सी # में (निर्देशिका) पथ की तुलना कर सकते हैं? ब्रॉडकास्ट रिसीवर में यूआई को कैसे अपडेट करें पायथन: सूची पर जाने के दौरान सूची तत्व को हटाने Ggplot2 द्वारा उत्पन्न भूखंड के नीचे पाठ प्रदर्शित करना मानव-पठनीय स्ट्रिंग के आकार को परिवर्तित करने के लिए ओब्जेसी / कोको क्लास? पायथन – नेस्टेड सूची के दूसरे कॉलम में अधिकतम मान ढूँढना एंड्रॉइड अलार्म सेवा के तत्काल ट्रिगर को रोकने के लिए अगर दिन के लिए अलार्म का समय बीत चुका है स्क्रिप्ट और फ़्लोटिंग-पॉइंट में प्रभाग मैं उबंटू पर PhantomJS कैसे सेटअप और चला सकता हूँ? कैसे (* SKIP) या (* F) regex पर काम करते हैं?

ctorParameters.map angular2-mdl में एक फ़ंक्शन नहीं है

मैं कोण-क्ली के साथ कोणीय 2-एमडीएल का उपयोग करने की कोशिश कर रहा हूं मैंने MdlModule में मॉड्यूल MdlModule आयात किया। मॉड्यूल।

जब मैं <mdl-textfield type="text" label="Text..." floating-label></mdl-textfield> का उपयोग करने की कोशिश करता हूं, तो यह एक त्रुटि बनाता है:

ctorParameters.map angular2-mdl में एक फ़ंक्शन नहीं है

मुझे नहीं पता कि मुझे क्या करना चाहिए।

यहाँ मेरा कोणीय- cli.json है

  "dependencies": { "@angular/common": "~2.0.0", "@angular/compiler": "~2.0.0", "@angular/core": "~2.0.0", "@angular/forms": "~2.0.0", "@angular/http": "~2.0.0", "@angular/material": "^2.0.0-alpha.9-3", "@angular/platform-browser": "~2.0.0", "@angular/platform-browser-dynamic": "~2.0.0", "@angular/router": "~3.0.0", "@types/moment-timezone": "^0.2.33", "angular-cli": "^1.0.0-beta.17", "angular2-jwt": "^0.1.25", "angular2-mdl": "^2.9.0", "bootstrap": "^3.3.7", "bourbon": "^4.2.7", "core-js": "^2.4.1", "font-awesome": "^4.7.0", "hammerjs": "^2.0.8", "moment": "^2.17.1", "moment-timezone": "^0.5.10", "node-sass": "^3.13.0", "primeng": "^1.1.0", "rxjs": "5.0.0-beta.12", "ts-helpers": "^1.1.1", "zone.js": "^0.6.23" }, "devDependencies": { "@types/jasmine": "^2.2.30", "@types/moment": "^2.13.0", "@types/moment-timezone": "^0.2.33", "@types/node": "^6.0.42", "angular-cli": "1.0.0-beta.17", "bootstrap-sass": "^3.3.7", "codelyzer": "~0.0.26", "jasmine-core": "2.4.1", "jasmine-spec-reporter": "2.5.0", "karma": "1.2.0", "karma-chrome-launcher": "^2.0.0", "karma-cli": "^1.0.1", "karma-jasmine": "^1.0.2", "karma-remap-istanbul": "^0.2.1", "protractor": "4.0.9", "ts-node": "1.2.1", "tslint": "3.13.0", "typescript": "2.0.2" } 

वेब के समाधान से एकत्रित समाधान "ctorParameters.map angular2-mdl में एक फ़ंक्शन नहीं है"

ऐसा लगता है कि इस सवाल के लिए कुछ स्पष्टीकरण की आवश्यकता है:

हम इस त्रुटि संदेश को क्यों देखते हैं?

यदि कोणीय 2 के लिए एक घटक लाइब्रेरी एओटी के साथ संगत होना चाहता है तो उसे एनजीसी (@ कोणीय / कंपाइलर-सीएलआई) के साथ संकलित किया जाना चाहिए। यह प्रत्येक घटक के लिए * .metadata.json फ़ाइलें उत्पन्न करेगा। इसके अलावा यह प्रत्येक घटक के लिए जेएस फाइल बनाता है जिसमें कंस्ट्रक्टर मापदंडों के बारे में जानकारी शामिल होती है। अगर पैकेज को @ कोणीय / कंपाइलर-सीएलआई <2.3.0 के संस्करण के साथ संकलित किया गया था तो यह (उदाहरण के लिए) होगा:

 MdlBadgeDirective.ctorParameters = [ { type: ElementRef, }, { type: Renderer, }, ]; 

यदि पैकेज को एक नया संस्करण के साथ संकलित किया गया है तो यह होगा:

 MdlBadgeDirective.ctorParameters = function () { return [ { type: ElementRef, }, { type: Renderer, }, ]; }; 

जैसा कि आप देख सकते हैं कि नया संस्करण फ़ंक्शन है और अब कोई सरणी नहीं है। तो त्रुटि

ctorParameters.map फ़ंक्शन नहीं है

समझ में आता है। क्योंकि नक्शा सरणी का सदस्य है, लेकिन फ़ंक्शन की नहीं।

इस समस्या को हल कैसे करें?:

  1. आप अपने कंकाल संस्करण (या संकुल जो आपके कोनेबल 2 कोड संकलित करने की कोशिश कर रहे हैं) को नए कंपाइलर आउटपुट स्वरूप में अपडेट कर सकते हैं। उदाहरण कम से कम @angular / * @ 2.3.1 (यदि आप कोणीय-क्ली का उपयोग कर रहे हैं तो आपको अपना प्रोजेक्ट को कोणीय-cli@1.0.0- beta.24 पर अपग्रेड करना चाहिए)

  2. आप उस पैकेज को लॉक कर सकते हैं जिसे आप पुराने संस्करण से पुराने संस्करण से मेल खाने वाले प्रारूप में उपयोग कर रहे हैं। Angular2-mdl के लिए यह संस्करण 2.7.0 है। आप यहां यह जानकारी पा सकते हैं: https://github.com/mseemann/angular2-mdl#remarks

क्या किसी ऐसे पैकेज का उपयोग करना संभव है जो एक पुराने कोणीय-संकलक- cli के साथ संकलित किया गया था, जो एक नया कोणीय-संकलक-सीएलआई संस्करण है? (जैसे आप कोणीय 2.4.1 पर हैं और angular2-mdl@2.7.0 का उपयोग करना चाहते हैं) हां! यह दिशा पिछड़ा संगत है। https://github.com/angular/angular/blob/master/modules/%40angular/core/src/reflection/reflection_capabilities.ts#L80 देखें

मेरे पास एक ही समस्या थी (एक और प्लगइन के साथ) और इसे नवीनतम संस्करण (2.4.1) को कोणीय उन्नयन करके हल किया।

संपादित करें: पूर्ण पैकेज। जेसन

अपने टाइपस्क्रिप्ट संस्करण को भी देखें। संकलन करते समय मुझे सतत समस्याओं के कारण कोनेरी-क्ली का उपयोग करना बंद करना पड़ा। मैंने वेबपैक पर स्विच किया

 { "name": "web-app", "version": "1.0.0", "scripts": { .... }, "license": "UNLICENSED", "dependencies": { "@angular/common": "~2.4.1", "@angular/compiler": "~2.4.1", "@angular/compiler-cli": "^2.4.1", "@angular/core": "~2.4.1", "@angular/forms": "~2.4.1", "@angular/http": "~2.4.1", "@angular/platform-browser": "~2.4.1", "@angular/platform-browser-dynamic": "~2.4.1", "@angular/platform-server": "^2.4.1", "@angular/router": "~3.4.1", "codelyzer": "^1.0.0-beta.3", "concurrently": "^3.1.0", "core-js": "^2.4.1", "reflect-metadata": "^0.1.8", "rxjs": "5.0.1", "tslint": "^4.2.0", "typescript": "^2.1.4", "typings": "^2.1.0", "zone.js": "^0.7.4", ... }, "devDependencies": { "@angular/compiler-cli": "^2.4.1", "@ngtools/webpack": "^1.2.1", "extract-text-webpack-plugin": "^1.0.1", "ts-loader": "^1.3.3" } } 

मैं ng build से त्रुटि रिपोर्ट को देखकर इस मुद्दे का कारण जानने में सक्षम था:

 npm WARN @angular/platform-server@2.4.4 requires a peer of @angular/core@2.4.4 but none was installed. 

इससे मुझे एहसास हुआ कि मेरे संकुलों में से एक को कोणीय को v2.4.4 पर होना चाहिए, लेकिन मैं v2.0.1 का उपयोग कर रहा हूं। मैंने अपने पैकेज को अपडेट किया है। जेएसएन ने मेरे मूल संस्करण में इस तरह से दोनों संकुल सेट किए हैं:

 "dependencies": { "@angular/core": "2.0.1", "@angular/platform-server": "2.0.1", } 

आपका मुद्दा @ कोणीय / प्लेटफ़ॉर्म-सर्वर के साथ नहीं हो सकता है, लेकिन मुझे उम्मीद है कि यह इसे डिबग करने में सहायता करता है

मुझे यही समस्या थी यह कारण था क्योंकि मैं उपयोग कर रहा था

"एनजी 2-बूटस्ट्रैप": "1.3.1",

"@ कोणीय / सामान्य": "2.0.1",

"@ कोणीय / संकलक": "2.0.1",

"@ कोणीय / कोर": "2.0.1",

"@ कोणीय / प्लेटफ़ॉर्म-ब्राउज़र": "2.0.1",

फिर मैंने कोनेरी निर्भरता को अपडेट किया

"@ कोणीय / सामान्य": "2.2.3",

"@ कोणीय / संकलक": "2.2.3",

"@ कोणीय / कोर": "2.2.3",

"@ कोणीय / प्लेटफ़ॉर्म-ब्राउज़र": "2.2.3",

यह ठीक काम किया

2.4.6 कोण के उन्नयन के बाद यह ठीक काम करता है

  "dependencies": { "@angular/common": "2.4.6", "@angular/compiler": "2.4.6", "@angular/compiler-cli":"2.4.6", "@angular/core": "^2.4.6", "@angular/forms": "2.4.6", "@angular/http": "2.4.6", "@angular/platform-browser":"2.4.6", "@angular/platform-browser-dynamic":"2.4.6", "@angular/platform-server":"2.4.6", "@ionic/storage": "1.1.6", "@types/jasmine": "2.5.37", "@types/moment-timezone": "^0.2.34", "@types/request": "0.0.33", "angular-qrcode": "^6.2.1", "angular2-fullcalendar": "^1.1.1", "angular2-qrcode": "^2.0.0", "angularfire2": "2.0.0-beta.6", "ionic-angular": "^2.0.0-201702062042", "ionic-native": "2.2.3", "ionicons": "3.0.0", "moment": "^2.17.0", "ng2-signalr": "^2.0.3", "rxjs": "5.1.0", "zone.js": "0.7.6" }, 

मैं एक अपेक्षाकृत "प्राचीन" अंगुल्य 2 एप्लिकेशन (संस्करण 2.0.0 का उपयोग करता है) और एनजी-बूटस्ट्रैप को फिर से बनाने की कोशिश कर रहा था। परियोजना को सफलतापूर्वक बनाने के बाद (यानी, कोई त्रुटि नहीं) मुझे मुख पृष्ठ पर यह त्रुटि मिल रही है I

अपने आप को गला घोंटने की पूरी कोशिश करने के बाद, मैंने सभी एनपीएम मॉड्यूल की स्थापना रद्द की और एक npm install करने की कोशिश की और पाया कि एनजी-बूटसाप ने एक संस्करण स्थापित किया है जो अंगुलारे 2.0.0 के साथ संगत नहीं है ( ng-bootstrap लिए पैकेज। जेसन सेटिंग ~1.1.3 सेट) उस ने नवीनतम 1.1.7 स्थापित किया था, जिसकी आवश्यकता 2.4.x

2.4.x अपग्रेड करने की कोशिश करना एक बड़ा प्रयास साबित हुआ, इसलिए मैंने एनजी-बूटस्ट्रैप को 1.1.4 में सेट किया।

टीएल; डीआर: एन्जिलर 2.0.0 और एनजी-बूटस्ट्रैप का उपयोग कर रहा है। 2.4.x में अपग्रेड करना नहीं चाहता, इसलिए मैं एनजी-बूटस्ट्रैप संस्करण को 1.1.4 में हार्ड-कोडित किया और समस्या दूर चली गई।