दिलचस्प पोस्ट
बाहरी ".js" फ़ाइलों का उपयोग कैसे करें App.config / web.config के भीतर चर 'स्थानीय सिस्टम' खाते और 'नेटवर्क सेवा' खाते के बीच अंतर क्या है? एफिल्फ़ (स्टडिन) का काम नीचे कोड में आउटपुट कैसे बदलता है? क्या यूनिट परीक्षण में प्रतिबिंब का उपयोग करने के लिए बुरा अभ्यास है? टर्नेरी ऑपरेटर?: बनाम इफ … और Windows 7 में एक स्थापित एप्लिकेशन के अपग्रेडकोड ​​और उत्पादकोड को कैसे खोजें जावास्क्रिप्ट में किसी ऑब्जेक्ट की चाबियाँ / गुणों की कुशलता कैसे गिनेंगी? सभी आधुनिक ब्राउज़रों में पृष्ठ ज़ूम स्तर कैसे पता लगा सकता है? क्यों maven jdk 1.6 का उपयोग करें, लेकिन मेरा जावा-विजन 1.7 है क्रोम में विवादास्पद सत्यापन डीडी / एमएम / याय के साथ मान्य नहीं होगा वैकल्पिक आभासी तंत्र क्रियान्वयन? jQuery अजाक्स फ़ाइल अपलोड करें मैट्रिक्स की पंक्तियों को सॉर्ट करने के लिए जोर कैसे उपयोग करें? अजगर – स्थानीय डेटटाइम के लिए UTC डेटटाइम स्ट्रिंग कन्वर्ट करें

कम्पास के साथ संसा 3.3 है?

मैंने अभी Sass 3.3 में अपग्रेड किया है ताकि मैं कुछ नई सुविधाओं (बीईएम स्टाइल क्लास नाम, मैपिंग, @ एट-रूट आदि) का उपयोग कर सकूं। अगर मैं सास (एसस – sass --watch ) के साथ मेरी परियोजना संकलित करता हूं, तो यह ठीक काम करता है। हालांकि, अगर मैं कम्पास ( compass watch माध्यम से) का उपयोग करके इसे संकलित करता हूं, तो मुझे नई Sass सुविधाओं का उपयोग करते समय एक त्रुटि मिलती है

मैं कम्पास 0.12 का उपयोग कर रहा हूँ

वेब के समाधान से एकत्रित समाधान "कम्पास के साथ संसा 3.3 है?"

कम्पास 0.12 स्पष्ट रूप से Sass 3.2 पर निर्भर करता है। यहां तक ​​कि अगर आपके पास Sass का एक नया संस्करण स्थापित है, तो यह अभी भी 3.2 के साथ संकलित करेगा। Sass 3.3 या बाद का उपयोग करने के लिए, आपको कम्पास 1.0 या बाद के संस्करण का उपयोग करना होगा।

मणि इंस्टॉल कमांड चलाने से आपको नवीनतम स्थिर संस्करण मिलना चाहिए।

 gem install compass 

उस समय इस सवाल पर पूछा गया, कम्पास 1.0 अभी भी बीटा में था। एक मणि के नवीनतम बीटा संस्करण को स्थापित करने के लिए, आपको --pre ध्वज का उपयोग करके इसे स्थापित करना होगा।

 gem install compass --pre 

ध्यान दें कि आपको काम करने के लिए पहले Sass को स्थापित करने की आवश्यकता नहीं है। कम्पास स्थापित करने से Sass के नवीनतम संस्करण को स्वचालित रूप से स्थापित किया जाएगा जो कि इसके साथ संगत है।

मैं कम्पास 1.0 स्थापित है और यह अभी भी त्रुटियों

  • हो सकता है कि किसी भी अन्य निर्भरता को डबल करें (कम्पास एक्सटेंशन, आदि), उनमें से एक Sass या Compass के पुराने संस्करण को निर्दिष्ट कर सकता है
  • यदि आप सीधे आदेशों का उपयोग करने के बजाय किसी एप्लिकेशन या बिल्ड टूल का उपयोग कर रहे हैं, तो सुनिश्चित करें कि वे कम्पास के पुराने संस्करणों को नहीं संदर्भित कर रहे हैं

विंडोज़ प्रयोक्ता

एक विंडो उपयोगकर्ता के रूप में, मुझे एक त्रुटि मिली जब मैंने नई कम्पास का उपयोग करके मेरी प्रोजेक्ट देखने की कोशिश की

लोड करने पर त्रुटि ["36"] सी का: ऐसी फ़ाइल लोड नहीं कर सकता- wdm "

उस समस्या को ठीक करने के लिए:

आपको रूबी देवकिट स्थापित करना होगा: डाउनलोड यहां मिले: http://rubyinstaller.org/downloads/

ठीक से स्थापित करने के लिए इस पृष्ठ का पालन करें: https://github.com/oneclick/rubyinstaller/wiki/Development-Kit

अब wdm स्थापित करें:

 gem install wdm 

ऐसा कोई ऐसा स्थान नहीं दिखता, जिसमें यह कार्य करने के लिए आवश्यक चरणों की पूरी सूची होती है, इसलिए ये यहां हैं। यह सूची विंडोज के लिए है, लेकिन यह अन्य प्लेटफार्मों पर ठीक काम कर सकता है

  1. रूबी स्थापित करें – 1.9.3 का उपयोग करें – http://rubyinstaller.org/downloads

  2. रूबी DevKit डाउनलोड करें एक ही पृष्ठ पर कम पाया – http://rubyinstaller.org/downloads/ इसे कहीं और (स्थायी) निकालने के लिए चलाएं। उसके बाद सीडी, "रूबी डीके। आरबी इनट" और "रूबी डीके। आरबी इंस्टॉल" को अपने पथ में रूबी इंस्टॉल करने के लिए बाँध लें।

  3. मणि स्थापित wdm

  4. मणि स्थापित sass

  5. मणि इंस्टॉलेशन कंपास – प्री

यह अब कम्पास के नवीनतम संस्करण में है परिवर्तन प्राप्त करने के लिए कम्पास को अपडेट करें और Sass 3.3 और उच्चतर के साथ काम करें

वर्तमान सास संगतता यहां पायी जा सकती है: https://rubygems.org/gems/compass

बस चलाने के उन्नयन के लिए

 $gem install compass